[CCMP] Issues with Cleura Cloud Management Portal

Resolved
Duration: 1hMar 12, 2026

Affected services

Cloud Management portal

Major outage

Timeline

Resolved
15:13Mar 12, 20261mo ago

We have not seen, or had reported, any further issues with the Cleura Cloud Management Portal, and consider this incident resolved. All systems are operating normally.
Thank you for your patience as we have been working to resolve this incident.

Cloud Management portal
Monitoring
14:21Mar 12, 20261mo ago

The issue appears to have been resolved and the portal should be fully accessible again. Our team is continuing to monitor the situation closely to ensure stability and confirm full recovery before marking the incident as resolved.

Cloud Management portal
Identified
13:57Mar 12, 20261mo ago

We have identified the cause of the issue and are working to resolve it. The preliminary estimated time to resolution is approximately 30 minutes, though this may change. We will provide additional updates as more information becomes available.

Cloud Management portal
Investigating
13:31Mar 12, 20261mo ago

Our Operations team is investigating issues with Cleura Cloud Management Portal.

During this time you may be unable to access Cleura Cloud Management Portal.

We apologize for the inconvenience caused and we will share an update as soon as we have more information.

Cloud Management portal