STO2 - Block Storage degraded performance
Resolved
Duration: 20mJul 24, 2025Affected services
STO2 - Block Storage
Degraded
Timeline
Resolved
12:35Jul 24, 20258mo ago
We have resolved the incident.
STO2 - Block Storage
Investigating
12:15Jul 24, 20258mo ago
Our Operations team is investigating an issue with the Block Storage in the STO2 region.
During this time you may experience lower than typical performance of the Block Storage, including higher read and write latency.
STO2 - Block Storage
