We are currently investigating issues affecting Block Storage in the FRA1 region.

  • Now
  • Jun 12, 2025, 3:56:12 AM GMT+2
    Resolved

    We have resolved the incident.

  • Jun 12, 2025, 3:28:40 AM GMT+2
    Monitoring

    We have fixed the issue and are monitoring the affected services.

  • Jun 12, 2025, 3:28:27 AM GMT+2
    Identified

    We have identified the root cause for this incident and are fixing it.

  • Jun 12, 2025, 3:09:27 AM GMT+2
    Investigating

    Our team has detected issues impacting Block Storage services in the FRA1 region. Users may experience difficulties accessing or managing their storage volumes. We are actively investigating the root cause and will provide updates as soon as more information is available. Thank you for your patience while we work to resolve this issue.

    FRA1 - Block Storage